Warning: count (): Parameter must be an array or an object that implements Countable…

This warning related to latest PHP7.2 version

If you see warning like this Warning: count(): Parameter must be an array or an object that implements Countable in …/wp-includes/post-template.php on line 284

This is an issue not with the theme, but with wordpress itself https://core.trac.wordpress.org/ticket/42814 . You need to wait WordPress update, WordPress developer will fix this. It should be fixed in WordPress 4.9.5

To fix this warning, you can downgrade PHP version to 7.1

Or disable warning reports in the wordpress by editing wp-cofig.php file.

You need to replace

define('WP_DEBUG', false);

to

ini_set('display_errors','Off');
ini_set('error_reporting', E_ALL );
define('WP_DEBUG', false);
define('WP_DEBUG_DISPLAY', false);

0